Error messaage when cliking the menu item

Feel free to talk about everything related to our Joomla Products
Rate this topic: Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.0 out of 6 based on 0 vote(s)
I have just installed the Boutique template and when I click on the Blog menu item it comes up with the following error. What is the problem?

JUser: :_load: Unable to load user with ID: 42


Thanks
George
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 9:30 am


This is a generic issue with Joomla and quick start packages. You will need to edit your database with phpmyadmin.

Below is the steps. Please backup your database before making changes. Change "Jos" with your prefix as it might be different.

1. Open your Joomla database using PHPMyadmin tool.
2. Open "jos_users" table,
3. Find record with "Super User" name and click on edit icon,
4. Change Super User id value to 42 and click on "Go" button,
5. Open "jos_user_usergroup_map" table.
6. Find the record with "group_id" value 8, change "user_id" value to 42, then click on "Go" button,
7. Logout and login again.

See you around...
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 9:42 am


I'm also a member over at Yootheme and I've never had this error with their quickstart installations. Is this specific to the GK Quickstart installation?
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 9:51 am


No it is to do with joomla and creating a quickstart package. If you search the error on the internet you can see other providers also have same error. It might be caused on version of Mysql while exporting data to create a quick start package.

See you around...
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 9:53 am


I've just done everything that you advised and the error is still there. I've gone back into the database and it is now showing user : 42

the domain is

http://www.georgeanderson.me

Regards
George
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 10:10 am


If both Jos_User and jos_user_usergroup_map are showing id 42 for super admin then it should work. Can you perhaps clear your cookies, logout then login again.

Let us know how you get on.

See you around...
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 10:20 am


I've cleared the cache and logged out and then back in and the error is still there.

Here...

http://www.georgeanderson.me/index.php/blog

Could it have anything to do with Akeeba Admin Tools?

Regards
George

I might try a fresh quickstart install again
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 10:24 am


If you can access the backend , try to create a new super user. If successful you can delete the old one.

If there are extra modules not using "$userId" variable properly it can cause your error. But in clean joomla packages this shouldn't happen.

I have reproduced this error in my local server simply by changing userid in database then changing it back to id42 which is default id for Super User error message is gone.

So in your case I ll try to install quickstart package and see if i can reproduce the error.

I ll keep you posted.
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 10:43 am


Just installed a quickstart package and it is using 886 id for Super User. So changing 886 back to 42 in those 2 tables I have mentioned fixes this error.

See you around...
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 10:56 am


Thank you for this. I am currently performing a fresh install and will see what happens. Is there not an inherent security issue with using userid 42? Is that not why you are able to change it with Akeeba Admin?

Regards
George
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 3:08 pm


I simply cannot get this to work. I've changed the database to user 42 but it is still showing as 68 in Joomla. I've just added a new different superuser and that is id 69

Please help!

George
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 3:52 pm


Which module etc within the Template is forcing user id 42?
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 4:12 pm


Can someone please help me. The error is still there!
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Jun 22, 2012 6:18 pm


I ve checked more on this issue and it is related to K2 items and comments. Original demo items are created with userid 42 and when this id is changed K2 is still looking for UserID42.

What you can do is delete the K2 items and Comments or you need to change userID ( created by ID ) from K2 to match your current userID. You can run below SQL command in phpmyadmin which will change it for you.

Please change following to match your database.
Jos = Your database prefix.
100 = Your new ID which you can see in joomla users.
Run each sql separately please.
Code: Select all
UPDATE `jos_k2_items` SET `created_by` = '100',
`modified_by` = '100' WHERE `jos_k2_items`.`created_by` =42

Code: Select all
UPDATE `jos_k2_comments` SET `userID` = '100' WHERE `jos_k2_comments`.`userID` =42;


See you around...
User avatar
normanUK
Moderator
Moderator

Fri Jun 22, 2012 8:52 pm


Many thanks for all of your help normanUK.

It's much appreciated !!!

Best Wishes
George (uk)
User avatar
Borders
Expert Boarder
Expert Boarder

Sat Jun 23, 2012 1:00 pm


Thanks!, it worked right away!
--
Take a look at our downloads section
http://www.mgscreativa.com/contenidos/index.php?option=com_docman&Itemid=214

MGS Creativa - VirtueMart Payment Plugin Experts
http://www.mgscreativa.com
User avatar
razor7
Junior Boarder
Junior Boarder

Wed Jun 27, 2012 8:11 pm


No problem at all, see you around...
User avatar
normanUK
Moderator
Moderator

Thu Jun 28, 2012 11:51 pm


Many thanks . . .
User avatar
Michael Michael
Fresh Boarder
Fresh Boarder

Mon Jul 09, 2012 9:45 pm


No problem at all. See you around...
User avatar
normanUK
Moderator
Moderator

Tue Jul 10, 2012 1:55 am


I get this error ??!

JUser: :_load: Kan ikke indlæse bruger med id: 42


www.innocentclan.dk
Please help me fast.
User avatar
smolf
Fresh Boarder
Fresh Boarder

Tue Aug 21, 2012 4:34 pm


Solution has been already posted in this topic, have you tried below.

See you around...
User avatar
normanUK
Moderator
Moderator

Fri Aug 24, 2012 11:26 am


normanUK posted this and it works perfectly...

This is a generic issue with Joomla and quick start packages. You will need to edit your database with phpmyadmin.

Below is the steps. Please backup your database before making changes. Change "Jos" with your prefix as it might be different.

1. Open your Joomla database using PHPMyadmin tool.
2. Open "jos_users" table,
3. Find record with "Super User" name and click on edit icon,
4. Change Super User id value to 42 and click on "Go" button,
5. Open "jos_user_usergroup_map" table.
6. Find the record with "group_id" value 8, change "user_id" value to 42, then click on "Go" button,
7. Logout and login again.

See you around...
User avatar
Borders
Expert Boarder
Expert Boarder

Fri Aug 24, 2012 11:31 am


Confirming - solution from normanUK using phpAdmin query works perfectly!
Thank you Norman :)
User avatar
perina
Senior Boarder
Senior Boarder

Mon Jan 13, 2014 6:35 am


I just wanted to thank NormanUK for the help with this SQL code - it fixed the error for me too! I was using QS for Shop and Buy!

It was not clear to me at first, but check your CURRENT user ID and replace the ID of '100' he listed above. Also replace '42' in the example above with the ID generated by the error.

For example - my error was:

Warning JUser: :_load: Unable to load user with ID: 213

So I replaced '42' in NormanUK's example with 213 !!
User avatar
mkahrhoffod
Fresh Boarder
Fresh Boarder

Wed Mar 05, 2014 3:59 am



Return to Discussion
cron