An error occured during parsing XML data.

Easy to use and free Joomla module to display weather with forecast from Yahoo.
Rate this topic: Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.Evaluations: 0, 0.00 on the average.0 out of 6 based on 0 vote(s)
Hi,

at first it worked but now i got this error message in the module position:

An error occured during parsing XML data. Please try again.


Also in the head of the website there is this message:

XML Parsing Error at 2:32. Error 76: Mismatched tag



Have you any solution?


Best regards,
Theo


EDIT: I added the xml file of the weather-module
User avatar
Tk1990
Fresh Boarder
Fresh Boarder

Mon Apr 05, 2010 10:09 pm


Hi

Please check permissions on mod_gk_weather.xml file.
This file must have full permissions.

Also, please check if you have php_curl.dll extension enable on your php.ini.

Cheers
User avatar
Seichinha
Moderator
Moderator

Tue Apr 06, 2010 2:04 am


Hi

Please also do not forget to clear cache for GK Weather.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Tue Apr 06, 2010 5:12 pm


cURL support enabled .

when you say full file permissions on the XML file, do you mean 777 ?

I tried everything.. but I still have the error message..
see www.ha-hai.com
on the top there I am supposed to have the Bangkok weather.

brgds Thomas

EDIT: my hostmaster turned on cURL, I thought it was on, as it was stated something like that in the php info. now it works.
Useful tread. Thanks.

Thomas
User avatar
thomasjojo
Senior Boarder
Senior Boarder

Sat Jul 03, 2010 8:51 am


Hi, I have the same problem
cUrl enabled and 777 over folder and xml files

with PHP4 I have no problems, but if I enable PHP5 the module show up the error message

Help please
User avatar
manuel_84
Junior Boarder
Junior Boarder

Tue Jul 13, 2010 10:34 pm


The same exact issue has just started without warning, the site has been live for months now without an issue.

I've tried 777 on the xml file and cleared cache, also cURL seems fine...

cURL support = enabled
cURL Information = l/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

The site is quite complex so I don't really want to switch to php4.

Any ideas?
User avatar
Jane Blonde
Expert Boarder
Expert Boarder

Tue Jul 20, 2010 12:14 am


Jane Blonde wrote:
The same exact issue has just started without warning, the site has been live for months now without an issue.

I've tried 777 on the xml file and cleared cache, also cURL seems fine...

cURL support = enabled
cURL Information = l/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

The site is quite complex so I don't really want to switch to php4.

Any ideas?


try to check this topic: http://www.gavick.com/forum/71-gk-weath ... html#58242
User avatar
manuel_84
Junior Boarder
Junior Boarder

Tue Jul 20, 2010 12:25 am


this post might shed a little light on the issue...
http://www.rockettheme.com/forum/index. ... ic#p528523
User avatar
Jane Blonde
Expert Boarder
Expert Boarder

Tue Jul 20, 2010 12:49 am


Hello
Meme the same problem as my predecessors. Surely it is not associated with Google as a free module specially installed SP WEATHER who at the time worked. The module operates once again does not work and I do not know what it is due. I have set permissions to 777 so that it is not the cause.

In the appendix proves that another module operates at the same time.
:)
Site is on Joomla 2.5.1
Please help solve the problem.
Regards Peter

sorry for my english translator but it helps me: D
Attachments
pogoda.jpg
the SP module is a module Gavick
pogoda.jpg (54.5 KiB) Viewed 7729 times
User avatar
Kolodziejczyk
Fresh Boarder
Fresh Boarder

Tue Feb 14, 2012 3:57 am


This SP Weather looks exactly like our module ;) Please attach some screen with module configuration, what is your cache time ?
User avatar
bkrztuk
Moderator
Moderator

Tue Feb 14, 2012 9:11 am


Hi

This can be also a problem on google. I've been once working on this problem when I relised that at this hour google shut down the server.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Tue Feb 14, 2012 12:40 pm


Welcome to the appendix setting
As for the google server, it can not be a problem if the second module is working.
I do not know what's going on but it usually stops działaś module does not work in the evening and overnight.
Attachments
general.jpg
general.jpg (55.91 KiB) Viewed 7705 times
User avatar
Kolodziejczyk
Fresh Boarder
Fresh Boarder

Tue Feb 14, 2012 7:18 pm


Hi

Please send me an access to joomla panel. I need to check the cache setting too.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Wed Feb 15, 2012 12:13 pm


Hi

I can see nothing under send address. Can You please tell me the right one ?

Code: Select all
The requested URL / was not found on this server.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Fri Feb 17, 2012 9:03 pm


In my case I figured out the issue is because Google is not returning current in the xml. Even in Google website you can see the issue. Check the weather at "Tacuarembo, Uruguay" or "Melo, Uruguay", compare it with "Montevideo, Uruguay" to see the difference. I think the problem could be fixed at helper.php.
User avatar
pabben
Fresh Boarder
Fresh Boarder

Tue Jun 12, 2012 4:09 am


Hi

Yes that's often an issue. Almost half of user reports about this problem was because of google server glitches. Unfortunately there is nothing we can do about it :(
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Tue Jun 12, 2012 10:58 am


teitbite wrote:Hi

Yes that's often an issue. Almost half of user reports about this problem was because of google server glitches. Unfortunately there is nothing we can do about it :(



Maybe get the weather module to silently use a backup copy of the last successful xml file that was generated
rather than plastering error messages across the webpage of website visitors.
User avatar
ncaa
Fresh Boarder
Fresh Boarder

Thu Aug 16, 2012 3:04 am


If you configured cache in module it should use the backup copy of data in fact when the service is unavailable for longer time the cached version is also updated and the problem come back.
User avatar
bkrztuk
Moderator
Moderator

Thu Aug 16, 2012 10:34 am


Hi

Please try use Yahoo as source. I've found it more stable.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Sat Aug 18, 2012 10:34 pm


both of the "solutions" put forth does not solve the underlying problem, they only mitigate somewhat the issue. i.e. the issue will always come back at some point.

The problem being that GK Weather module is unable to handle any availability errors in the weather feed in an effective way.

Suggested changes for a better module :),

1. Dont assume feed is always available. Silently use backup data regardless of the cache setting.

2. Change the helper file to separate feed code into individual files. This will allow more feeds to be used. i.e. I could then add an Australian specific feed thats available from the govt weather website.

3. Ensure the generated html is the same regardless of the feed used. This way you dont need to make styles for each feed.

4. Have the ability to select a secondary feed as a fallback, in the event the primary feed is unavailable.
User avatar
ncaa
Fresh Boarder
Fresh Boarder

Tue Aug 21, 2012 3:14 am


Hi

Ok. I will inform programmers about this idea.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Tue Aug 21, 2012 11:04 am


Hi

Can You please send me an access to Your joomla panel. I would like to check Your settings for this module.
---------------------------------------------------------------------------------------------------
Mailing me details please ALWAYS put a link to post as a topic!!! gk.teitbite@gmail.com

Want to hire me for custom job ? Check my portfolio first: http://www.teitbite.com/
User avatar
teitbite
Moderator
Moderator

Tue Aug 21, 2012 12:37 pm


Witajcie, kilka miesięcy temu wyłączyłem moduł GK Weather na stronie. Nie znalazłem nigdzie w sieci rozwiązania. Mam także moduł pogody z RT, ale problem był podobny. Po dokonywaniu poprawek według znlezioncyh źródeł, moduł dalej nie działał poprawnie - zmieniał się tylko komunikat błędu.

Dziś postanowiłem temat odświeżyć, zerknąłem na forum, dostosowałem się do znalezionych wskazówek lecz moduł dalej nie działa.

Czy ktoś z Was znalazł rozwiązanie, tak żeby moduł pogody zadziałał?

Moje ustawienia i wersje:

Joomla 1.5.26
GK Weather 1.3
cURL enabled
uprawnienia pliku XML ustawione na pełne 666
cache w module wyłączony, na stronie także

proszę o pomoc lub jakąkolwiek odp.
z góry dziękuje
User avatar
ahoj!
Fresh Boarder
Fresh Boarder

Tue Feb 05, 2013 9:38 pm


Weather module for J!1.5 is no supported and because of many changes in google API we advice to use only extension for J!2.5
User avatar
bkrztuk
Moderator
Moderator

Tue Feb 05, 2013 11:37 pm



Return to Weather
cron